Software Requirements

Parent Previous Next


Software Requirements


Before installing LegiTest, make sure you meet the following system requirements:

  SQL Server Integration Services 2005, 2008, 2008 R2, 2012, 2014, 2016

  BIDS 2005, 2008, 2008 R2 (Business Intelligence Development Studio) or SSDT 2010, 2012, 2014, 2016, 2017 (SQL Server Data Tools)

  Microsoft ® .NET 3.5 with Service Pack 1

  Microsoft ® .NET 4.0

  Microsoft ® .NET 4.5 (2017 Providers only)

  Microsoft ® SQL Server ® 2012 Transact-SQL ScriptDom x86


The following operating systems are supported by Workbench:

  64-bit (x64) Operating Systems:

o   Windows Server 2003 (at least Service Pack 2) *

o   Windows Vista (at least Service Pack 2)

o   Windows Server 2008 R2

o   Windows Server 2012

o   Windows Server 2016

o   Windows 7

o   Windows 8

o   Windows 10

  32-bit (x86) Operating Systems:

o   Windows XP (at least Service Pack 3) *

o   Windows Server 2003 (at least Service Pack 3) *

o   Windows Vista (at least Service Pack 2)

o   Windows Server 2008 R2

o   Windows Server 2012

o   Windows 7

o   Windows 8

o   Windows 10


Important Note

Windows XP and Server 2003 have been deprecated from full support. Any issues encountered on either Windows XP or Server 2003 must be reproducible on newer versions of Windows to be eligible for support.


LegiTest extension requires:

oAn installation of one of the following editions of Visual Studio:

  Visual Studio 2012 Pro or better

  Visual Studio 2013

  Visual Studio 2013 Community Edition

  Visual Studio 2015

  Visual Studio 2015 Community Edition

  Visual Studio 2017


  NUnit Requirements

o   NUnit 2.6.4 is required to execute LegiTest NUnit tests outside of Visual Studio

o   NUnit Test Adapter 2.0 is required for LegiTest NUnit tests to be displayed within the Visual Studio Test Explorer


The following prerequisites are required to enable features within LegiTest:

  SQL Server Assets

o   Supported Versions

  SQL Server 2008 R2

  SQL Server 2012

  SQL Server 2014

  SQL Server 2016

  SQL Server 2017


  SSIS Actions and Assets

o   Supported Versions

  SSIS 2008 R2

  SSIS 2012

  SSIS 2014

  SSIS 2016

  SSIS 2017

o   Each version of SQL Server Integration Services (2008 R2 or above) that the user wishes to test

o   SQL Server Data Tools or Business Intelligence Development Studio

o   Microsoft ® .NET 4.5 (Required by SSIS 2017 Only)

o   Note: The version of SQL Server Data Tools that provides the Integration Services designed within Visual Studio must be installed. This is a separate download to the version of SQL Server Data Tools that provides .sqlproj support that ships with Visual Studio.

  SSAS Actions

o   Supported Versions

  Multidimensional

  SSAS 2008 R2

  SSAS 2012

  SSAS 2014

  SSAS 2016

  SSAS 2017

  Tabular

  SSAS 2012

  SSAS 2014

  SSAS 2016

  SSAS 2017

o   Microsoft ® .NET 4.5 (Required by SSAS 2017 Only)


  SSRS Actions

o   Supported Versions

  SSRS 2008 R2

  SSRS 2012

  SSRS 2014

  SSRS 2016

  SSRS 2017